Jump to content

Search the Community

Showing results for tags 'falcon'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OzFalcon
    • OzFalcon News
    • New Member Introductions
    • Site Feedback
  • General
    • The Pits
  • Merlin's Metalcraft Emporium
    • Panel Beating Tech
    • Paint Tech
  • Technical
    • 6 Cylinder Tech
    • V8 Tech
    • Forced Induction Tech
    • Exhaust
    • Body and Exterior
    • Transmission and Differential
    • Steering, Suspension and Brakes
    • Cooling System
    • Interior and Car Audio
    • Auto Electrics
    • LPG Tech
    • Cortys and Eskys
    • Effies
    • Wheels and Tyres
  • Projects
    • Extreme Builds
    • Member Builds
    • Showroom
    • DIY
  • Trash 'n' Treasure
    • The Car Yard
    • The Wreckers
    • Non Car Related Sales
    • Wanted

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 8 results

  1. So basically, I installed the FALCON BA/BF - TERRITORY SX/SY AUDIO BOOSTER from ASL Media, everything is fine, the audio is 10x better so im happy, the day after my car battery is dead. I then buy a new battery and sure enough the thing is dead in less than 24 hours later. I then realise it is the Audio Booster causing this so I remove it and everything is fine again. If you dont know, the way this is installed is by plugging a female adapter into the blue male plug behind the fuze box of a BF falcon, So if anyone has any ideas on how this issue can be resolved I will love to see your replies so I can get my music back to a good quality. Thanks guys. Photo of the plug:
  2. Gday everyone, I recently brought me self a 1985 xf falcon but she had fairlane wheels on her so looking for whats out there at the moment to replace them. Cheers
  3. FAIRXF

    XF 250 crossy EFI problems

    Hey Guys, Recently I have replaced the push rods in my 250 and had to take out injectors ect.. it started before beginning the process and now it doesn't could it be a fuse? because i've tested the power at injectors and there is no power there. what could cause the injectors to not get power or the engine to not start? Thanks in advance
  4. falconguy

    Please help car won't run

    Hey fella's Please help!! I put a new head unit in my car and accidentally dropped this. How do i reset it or how do I fix?
  5. gerg

    V8 Exhaust Note

    OK, it has to be done. If your V8 sounds tits, then put it up here. I just ran in the cam on my XE 302 Wags this morning... Very happy after struggling to crank it yesterday with a shitty battery and cables. No mufflers, just straight out of the engine pipes. Not as loud as i thought it would be though. As you can hear, my little bloke loves it.
  6. Welcome Everyone, So I will give a quick run down of what this is, I've read heaps of the forums on here, especially those based around performance gains on the good ol' Crossflow. This forum, will be a kinda build topic, showing the build of the engine, specs, asking for help, giving you people information on what's happening. But most importantly, I wanted to create a forum, where I tell you guys what I'm doing, and what's going on, and you can give me specific answers and help to my issues and wants. Yes I know, there are heaps of build threads and forums and posts about gaining performance, but I want a post and forum specifically targeted at what I'm doing, so I can gain personalised help, as well as give results and insight to what I did for future project goers. Okay, so this is whats up, I started this build 5 years ago, and you can check it out on my other forum "Sleeping Beauty", I'm not going into detail with the build here, only engine related components. Alrighttyyy into the nitty gritty, quick rundown, engine rebuilt, everything nearly new, entire engine is balanced internally and externally including flex plate and pulleys. When motor was new it had a dry cranking compression of 210PSI. This is what it is running: - Stock OEM Cam - .050 Duration Int = 190 .050 Duration Exh = 190 Cam Lift Int = 234 Cam Lift Exh = 234 Valve Lift Int = 407 Valve Lift Ext = 407 - 350 Holley Performance Carby Jet Size = 52 - Redline Performance Manifold - PaceMaker Headers - 2 1/4 Inch Straight Pipe with Straight Through Muffler - Unknown Compression ratio, only know 210PSI dry cranking pressure - Converted to Unleaded Valves - Running 98 Octance Fuel - Mechanical Fuel Pump - Thermo Fans - MSD 6AL-2 Programmable Box with XF EFI dizzy and 8.5MM plug wires Okay, so that's a run down on the motor, I ran it in over 1000kms, and god was it a bitch, this thing had like 65 jets in it from the factory Holley tune, and it had original points ignition, so it just died, bogged, sucked absolute monkey b**l. Okay, I'll leave you guys with this last information, and will do an update in a day or so. I got the car dyno tuned after it was run in, had massive issues, the throttle wasn't even opening to full throttle only half, and when we did our first run, without any tune, we got a powerful 40RWKW, WOOOOO hahahaha So we fixed the throttle position, we pulled the jets straight down to 58, and then advance some timing, slowly slowly the power came up. Eventually, we ended the day on 53 jet size, timing, and without air filter 110RWKW and about 380NM of torque, and with the air filter on I lost 10RWKW, WOW, so turns out the air filter is super restrictive. Anyway, I'll leave you guys without for now, pretty late when I was writing this, will post some picks up with the work I just spoke about, and will then tell you what I've done next, where I am going, and ask a few questions I need help with. Thanks, harry ‚Äč
  7. Harrison Kotrolos

    Photos - Falcon XC Sedan

    Hey everyone, So I've been gone for a while, and got back into Sydney after that huge storm hit. And well my worse nightmares, the rear footwells of my Falcon XC Sedan were a pool, I honestly have no idea where it came from. So Going to start with the rubbers, maybe they aren't on right, and then get the doors aligned again, because they aren't aligned properly yet. It seems to be coming from the front doors but at the rear, because its wet under the front seats as well. Anyway, Could you lovely people please EMAIL, or POST, or MESSAGE, some photos of your cars, and your rubbers you got installed. Need detailed photos, from the door belt of the door, to the pinch weld and door frame rubbers, Need front and back doors and photos. It will be greatly apprectiated. Cheers, Harry
  8. xdfairmont79

    xm falcon engine build

    righto so iv got an old pre crossy out of an xt ute, its going to be done up for my xm and then it will be on the road.. i havent got very far with it yet haha its still in the xt ute but for the moment i would like to know the little tricky things about them i have to watch out for when im building it/ evaluating the block the head is not a problem i have a 2v head i bought a few years ago already being rebuilt for my xy falcon 500 but i will use it on the xm instead as we have gone the original route with the xy. this is the ute the engine is coming out of. im not sure if it is a 200 221 or 250 maybe even smaller but its not the original engine and the guy we got it from had xb's and xc's lying everywhere so the chances its a 250 are high. i dont really care what ci it is tbh but a 250 would be good. 221 is my next best always loved that number hahahaha.. anyway so thats the plan. its going in front of a 2 speed fordomatic aswell. and for my xm which is bassically a beach cruiser type car it will be very throw back mexican blanket seats type epicness! also if you have any good xm parts or know where some are contact me. thanks Cam types would be good aswell cause i want it to be tourquey and loud hahaha.
×