Jump to content
SteveHobart

Alloy issues

Recommended Posts

Hey all! Need some help.

 

Having some issues with the Alloys on the XF. Basically, the front wheels didn’t go over the hub on the new brakes (Disk Brake Australia Rotors). So I had them machined a couple of mm to clear it.

So now they clear the hubs ok, but the inside of the alloy fouls on the upper control arm when at full droop. I think this has always been the case.

So I obviously have to fix this issue and, to my mind, there are two ways I can go:

(A) get 4 x New Alloys which have the correct offset and centre hub measurement or;

(B) buy some wheel spacers (I am aware of the legalities of wheel spacers and I’m not convinced on the safety of them)

Would appreciate any ideas! I have attached two pics for illustration.

 

IMG_0061.HEIC

 

bc57c0e74e5111cc61971b4ddfa46051.jpg

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

i'd get different wheels. but i know Tassie isn't as easy as the mainland for getting things for anything old.
if you fitted spacers, would the wheel(tyre) to guard get any contact?

Share this post


Link to post
Share on other sites
Yep, those wheels will suit the XF heaps better!

I'm interested to know what the backspace offset is, on those old Alloy wheels?
(ie, nissan, Toyota etc)

Can you measure a wheel for us?
If they're for a Jap car, I'm surprised that the centre bore wasn't too small. They might be for AU-onwards Fords with a similar offset.

Sent from my CPH1607 using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×