Jump to content
motoSycho

New Motor for Rods Mad Maxy Ute

Recommended Posts

3 minutes ago, motoSycho said:
Lets see if this works.
 
Ummm, so yeah. But at least I have oil pressure and it was getting to the top like it should. Better luck tomorrow 😁
 

video works,

it's definitely got oil up top :) 

Share this post


Link to post
Share on other sites
5 minutes ago, deankdx said:

check the butterflies clear the manifold under the plate, could be close?

looks like a quality  part though

 

 

Will do. I'm not afraid to cut some out of it, if I need the extra room.

Share this post


Link to post
Share on other sites



Where did you get the lifting brackets your using from?, seem much better then the factory ford ones.




They came on some crossflow motors I picked up. 


They look like the normal xflow ones. Normally they bolt on the lower manifold holes not top ones, and I think they normally face the other way around.

Share this post


Link to post
Share on other sites




So what is this threaded hole for?
106487363_10158573499234516_4511585387193213163_o.jpg?_nc_cat=103&_nc_sid=8024bb&_nc_ohc=HP9s4G9quoUAX-9Qm6a&_nc_ht=scontent-syd2-1.xx&oh=5479483c4f53e8fc42642e2cd78fa117&oe=5F231D6E
 
 


Depending on whether it goes to a drilling that leads below the throttles or above them, it will either be a vacuum source or engine breather fitting, respectively.

If not used, definitely plug it. Looks like 1/4" or 3/8" NPT

Sent from my CPH1607 using Tapatalk

Share this post


Link to post
Share on other sites

More bits!
Today was all about running around town picking up packages and grabbing hoses etc. from Autobarn.
The banjo fitting for the Edelbrock arrived. Just waiting on the base gaskets now.
I'll need to cut some out of the East/West adapter and the pad of the manifold to make room for the carby butterflies and to get rid of some lips. Easy job to do.
And my Gilmer drive setup arrived!!!!
I also stopped in at the auto sparky and he will wire up my gauges, thermo fans and MSD ignition for me.

 

Does anyone have a diagram on which heater hose goes where, where the tap thing needs to go and where the vacuum line run to? I'm bypassing the manifold, as it won't be there anymore, and I have a mental blank on where the hoses went.

 

106935947_10158589933054516_888129091175

 

106228625_10158589932819516_371138862188

 

106922806_10158589932869516_523194737254

Share this post


Link to post
Share on other sites
19 minutes ago, dex said:

Xf has the three bolt harmonic balancer ,?

XF has 4 bolts, XE and prior 3 bolt.. same otherwise

Share this post


Link to post
Share on other sites
3 hours ago, motoSycho said:

Does anyone have a diagram on which heater hose goes where, where the tap thing needs to go and where the vacuum line run to? I'm bypassing the manifold, as it won't be there anymore, and I have a mental blank on where the hoses went.

 

 

without a photo.. 

 

the head heater pipes are OUT... and the water pump is IN.. (direction of flow) this is only relevant for the heater tap, as it may not open or may be pushed open if the flow is wrong. 
if you have 2 outlets still in the head.. just block one off if there's nothing else left to use. 

Share this post


Link to post
Share on other sites

 

 

 

 

Does anyone have a diagram on which heater hose goes where, where the tap thing needs to go and where the vacuum line run to? I'm bypassing the manifold, as it won't be there anymore, and I have a mental blank on where the hoses went.

 

 

 

You'll have to block one of the hose outlets from the head, and run the other one to the heater core, and then one from the water pump to heater.

Heater tap should be in hose from head, and that should go to the centre most heater pipe according to the workshop manual.

 

These are the diagrams from the Ford workshop manual, I've included both carby and EFI because really you're running the EFI style heater hose now872d585de623d5d1f55ddf85e572e091.jpg25e8b0749395769e3a001aa4cb43f38c.jpg

Share this post


Link to post
Share on other sites
20 minutes ago, deankdx said:

XF has 4 bolts, XE and prior 3 bolt.. same otherwise


remembered the bit with the supercharger pulleys ,, but could not remember the order ...

 

Share this post


Link to post
Share on other sites
12 hours ago, Mr Polson said:

 

 

 

 

 

You'll have to block one of the hose outlets from the head, and run the other one to the heater core, and then one from the water pump to heater.

Heater tap should be in hose from head, and that should go to the centre most heater pipe according to the workshop manual.

 

These are the diagrams from the Ford workshop manual, I've included both carby and EFI because really you're running the EFI style heater hose now

 

Awesome thanks! This is just what I needed 👍

Share this post


Link to post
Share on other sites

Yep same on my XF ute, blocked top water outlet from head, bottom outlet to heater tap, tap to heater box, heater box to water pump,

has a 5/8" barb to 5/8" barb fitting to extend the water pump hose. tho not hooked up at the moment as I need to replace the heater core as it was leaking,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×