Jump to content
xfish

El xr8 2 issues......

Recommended Posts

Hello people of oz falcon

i have purchased a j3 chip over 4 years ago, ( Increased to the au MAF 70mm, while retaining the el xr8 MAF with ss induction) and have not had an issue's ever until recently.........my el xr8 2 has seem to develop a few annoying  issues. Symptoms are when i put my foot down, it feels to hesitate before it accelerates, and if i stick to a consistent speed, i can feel it lightly hesitating, and have to accelerate to stop the hesitating. Hesitating in my terminology means, it feels like fuel is being restricted. And when i start the car on a cold morning, it starts up, but then have to push the accelerator to push the idle up before it stabilizers, because if i dont, the car will stall, but then i can fire it back up and she seems normal. I have replaced the fuel pump, fuel filter, air filter, brand new MAF and have a new isc on route to me currently. My fuel consumption has sky rocketed to 35 litres to 175km, where before i would get 400km to 60 litres ( 2 months ago ). I'm not really getting any higher rpm through the gears changes, but fuel consumption is killing me.  Any ideas?

Share this post


Link to post
Share on other sites

Sorry, I've orded the fuel pressure regulator, and have ordered new injectors since i have to remove the top manifold.........they just havent turned up yet.

 

Another problem has arisen on top or could be part of the same issue......

 

The 4 speed auto has worked fine and without issue.....and when ( on occasion ) i wanted a quicker start, I'd manually put it back to first and plant the foot. Today, I did this....and the car basically stood still.  It eventually got to 50 kmph, though it took 12 seconds ( yes , i timed it ). The normal power between 2nd -4th was there, though there was absolutely no power in first.....

 

a kid on a bike would kicked my ass............

 

any ideas?

Share this post


Link to post
Share on other sites
1 hour ago, xfish said:

The 4 speed auto has worked fine and without issue.....and when ( on occasion ) i wanted a quicker start, I'd manually put it back to first and plant the foot. Today, I did this....and the car basically stood still.  It eventually got to 50 kmph, though it took 12 seconds ( yes , i timed it ). The normal power between 2nd -4th was there, though there was absolutely no power in first.....

 

a kid on a bike would kicked my ass............

 

any ideas?

@SPArKy_Dave has this issue now ? 

Share this post


Link to post
Share on other sites

Gday, have you checked the Oxy sensors ? or replaced them ?

 

my ELXR8, had the hesitation when foot planted (say doing 80 and you wanted to go to100+), was the  MAF changed it over, and its fine now, still unable to resolve the fuel starvation when the tank is low going around corners or you boot it, so I just fill up again at half tank !..

Share this post


Link to post
Share on other sites
On 4/29/2019 at 2:14 PM, xfish said:

Sorry, I've orded the fuel pressure regulator, and have ordered new injectors since i have to remove the top manifold.........they just havent turned up yet.

 

Another problem has arisen on top or could be part of the same issue......

 

The 4 speed auto has worked fine and without issue.....and when ( on occasion ) i wanted a quicker start, I'd manually put it back to first and plant the foot. Today, I did this....and the car basically stood still.  It eventually got to 50 kmph, though it took 12 seconds ( yes , i timed it ). The normal power between 2nd -4th was there, though there was absolutely no power in first.....

 

a kid on a bike would kicked my ass............

 

any ideas?

 

Do you think it could have gone into Limp Home Mode (ie locked in 3rd) when you put it in "1" and took off? If manual shift in 1st put it into LHM, but in "D" it shifts 1-4th as normal, could be a faulty inhibitor switch. Just a thought.

Share this post


Link to post
Share on other sites

Hey all,

 

Well, i took the car to another mechanic, and was told the spring in the distributor was broken, and had the wrong sparkplugs, cause there is a big difference between the 170kw vs the 185kw EL XR8. .......they replaced it, and the car has DISCOVERED full power again, and gear changing has returned to normal. Though it still has a miss ( rough idle ) every so often......so, we're going for an exchange ecu, fuel injectors, and fuel regulator in a few weeks, just to freshen things up a bit.. Yes, I'm throwing money at the car,( though it is over 20 years old ) and still is stock  from factory, but a few pieces here and there. Hoping this will work.....because the mechanic and son have the same car as myself, and know the EL XR8 185kw backwards......will let you know the outcome after it's next visit.

Share this post


Link to post
Share on other sites

If your XR8 runs an EGR valve, (some do not) I would suggest to get it ultrasonically cleaned of carbon.

Also suss out the O2 sensors.

 

Both those can contribute to misfiring - especially at idle.

(vacuum leaks can also cause this)

 

The EFI Windsor dissy's don't have a spring-back centrifugal advance.

The only spring in them is on the rotor button, to help contact the center point on the dissy cap.

 

 

Share this post


Link to post
Share on other sites

yes, thats what broke. The dizzy was still the factory fitted dizzy ( we believe ), with having replaced only a few components in the last few years. And yes, it has the annoying egr setup, and would like to erase it completely .....oxygen sensors have been added to the list. We'll be pulling the top manifold off when we replace the fuel injectors, fuel regulator, so all gaskets can be replaced. So, now we're just waiting for the new ECU to arrive.

 

Also, I have a full top/bottom manifold from a ED sprint / throttle ,fuel rail etc ( i pulled it from a wreck 5 years ago, and has been sitting in my shed all that time ), which i would like mounted in place of the explorer manifold. Though i've searched high and low to see if there is any difference between the 2 manifolds, that putting it on the EL XR8 would/could cause issues. Visually, they look the same. Though i know the AU3 used the explorer manifold which was 220kw, as well the ED sprint was rated the same ( being known as the cheap GT ). Of course as stated before, we will replace all gaskets on the manifold before re-installing....just to assume if there is a leak on the manifold side of things.

 

right now, I'm happy with the  improved power on the factory side of things, though I have had a J3 chip ( stage 2 ) installed in the car for years, and that was pulled from the car when we started having issue's, and will be re-installing it after the gremlins have been squashed.

 

thoughts on replacing the top manifold?

Share this post


Link to post
Share on other sites
15 hours ago, xfish said:

thoughts on replacing the top manifold?

 

The upper and lower may need to be done together.

I don't think the cobra and explorer type uppers, will match up to the HO Mustang style lowers.

Share this post


Link to post
Share on other sites
sorry, that's what i meant. i should of said the top and lower manifold. my bad.....
Unless you're having dramas with it, I would leave it as is. EGRs don't work at full throttle so don't affect power. Apart from reducing NOx, they actually increase part throttle efficiency by reducing vacuum and pumping losses. The computer is tuned with this function in mind so operates on the assumption that the engine is ingesting X amount of EGR at Y amount of throttle. Go blocking it and the computer won't know to compensate, but you'll possibly use more fuel due to increased throttle opening at a given load/rpm.

If you don't understand all that jargon, basically don't fuck with it unless it's rooted.

Sent from my CPH1903 using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×