Jump to content

X-F250

Members
  • Content Count

    188
  • Joined

  • Last visited

About X-F250

  • Rank
    Advanced Member
  • Birthday 11/15/1995

Profile Information

  • Gender
    Male
  • Location
    Toogoolawah, QLD

Recent Profile Visitors

1,379 profile views
  1. X-F250

    NC Fairlane with watery fuel?

    Replaced the dizzy with the one that was on my old motor, the one that came out looked pretty tidy from the outside (reco'd Bosch I'd say) but was pretty sad looking on the inside. Still won't fire but I'd say the coil is trash since it's got some pretty decent cracks in the body and the spare one it was running on yesterday is much the same. Failing that, the only other thing I can think of that's stopping it from starting is a dying ECU. Sent from my SM-G973F using Tapatalk
  2. X-F250

    NC Fairlane with watery fuel?

    http://www.ozfalcon.com.au/index.php?/topic/8686-NC-Fairlane-with-watery-fuel?#entry251616 Sent from my SM-G973F using Tapatalk
  3. X-F250

    NC Fairlane with watery fuel?

    Ugh, it's not as fixed as I though it was. Went for a 40km drive this morning perfectly fine. Pulled up at home, switched it off and went upstairs. Came back out at lunch time and it wouldn't start again. Same as before, cranks fine, Smartlock seems to be working fine, just no spark. Could it be the hall effect sensor in the dizzy? Sent from my SM-G973F using Tapatalk
  4. X-F250

    NC Fairlane with watery fuel?

    Nah, bad fuel from the servo. I'm not the only one who's had problems. Sent from my SM-G973F using Tapatalk
  5. X-F250

    NC Fairlane with watery fuel?

    Turns out it had water in the fuel. Half a bottle of meto and some more 98 and she's good as gold again. Sent from my SM-G973F using Tapatalk
  6. X-F250

    NC Fairlane with watery fuel?

    Afternoon guys, Last week I put about $20 worth of regular 91 in the Fairlane and noticed it was running a bit rough afterwards but thought nothing of it since my coil was on its way out. The coil finally died yesterday so replaced it this morning (along with the TFI module, dizzy cap & rotor, new plugs & leads, etc) and it fired right up and idled beautifully. Thinking it was fixed I went to go for a run around the block. I got up the hill and around the corner, then all of a sudden it stumbled and almost cut out. Now if you give it more than about 1/4 throttle it cuts out, but only when it's in gear. It'll idle and rev fine in park and neutral but as soon as you select a drive gear it starts to play up. I did idle down to the servo to put a bit of premium in and it's slightly better, but still not really drivable. I did notice that it blows a bit of white smoke under acceleration as well. Any ideas? Sent from my SM-G973F using Tapatalk
  7. Just the 4 speed BTR in the NC. Probably should've mentioned that haha Sent from my SM-G973F using Tapatalk
  8. I'll go out and get a picture in the morning, but yeah, it definitely split. I've ordered a Ryco one off fleabay and I went down to Supercheap and grabbed another Transgold one in the meantime. Sent from my SM-G973F using Tapatalk
  9. Something to keep in mind: If the ute has a bench seat you'd likely have to put a set of buckets in to make it useable. Depending on which state you're in the swap requires a mod plate (because you're changing seating capacity), and in some of those states P-platers can't drive a mod-plated car, even for something as minor as a seat swap. Sent from my SM-G973F using Tapatalk
  10. Hey guys, Went to run down to the shops this arvo and noticed a lovely trail of trans fluid all the way down to the servo from when I went out this morning. Turns out the rubber gasket I put on the box when I swapped the motor a few months ago has split horizontally in the front left hand corner. I've used the Trangold kits several times and this is the first time something like this has happened. Anyone else ever had issues? Sent from my SM-G973F using Tapatalk
  11. X-F250

    NC Fairlane Fuel Pump Removal

    Hey guys, Got some updates on the old NC on the way, but at the moment it's immobile thanks to a dead fuel pump. I've got all the connectors and fuel lines unhooked, what's holding me up is the locking ring. I've tried belting it with a screwdriver and hammer, I've tried to use the old 2 screwdrivers and a prybar as a lever trick. Hasn't moved a mm. A lot of the little tabs are bent or damaged (looks like someone has tried to use a pair of pliers or something to try to undo it previously). Do you guys have any tips? I'm at my wits end with it and I'm tired of driving my broter's EA.
  12. X-F250

    NC Fairlane won't start

    Gave the dash a solid belting, still no luck. I'll have a talk with the old man about borrowing some bits off my brother's wrecked EB wags, getting tired of slumming it in his EA GL. Sent from my SM-G930F using Tapatalk
  13. X-F250

    NC Fairlane won't start

    Thanks Jack, but it's definitely not the battery. I swapped the new battery out of my Brother's EA, NC still wouldn't start but the EA started fine with the battery out of the Fairlane. Sent from my SM-G930F using Tapatalk
  14. X-F250

    NC Fairlane won't start

    Cheers, Dean. No luck with it coming good but I swapped the ignition relay out for one I know works and it didn't help so it looks like I'll be looking at a new ignition switch. Sent from my SM-G930F using Tapatalk
  15. X-F250

    NC Fairlane won't start

    Hey fellas I've had a problem with my NC. Been driving fine since I got it, although the dash lights flicker a little sometimes (probaby due for a new alternator). Last night, I parked in the driveway and locked up the car. When I went to leave for work this afternoon the car simply wouldn't start. Figuring the battery had run low I swapped it out for my spare, but there was no difference. Right now, the only things that seem to work are the interior lights, boot release and the smartlock light on the dash. When I turn the key over there's no dash lights, power windows, etc. Checked the engine earth and it seems fine. Thanks in advance, John Sent from my SM-G930F using Tapatalk
×