Jump to content

Aussieyobbo16

Members
  • Content Count

    37
  • Joined

  • Last visited

About Aussieyobbo16

  • Rank
    Newbie
  • Birthday October 2

Profile Information

  • Gender
    Male
  • Location
    Moe Victoria
  • Interests
    Cars. What else???

Recent Profile Visitors

339 profile views
  1. Aussieyobbo16

    issue with dual fuel xg

    yeah I feel ya. I’m just about at wits end with mine. Very interesting to have one as a first car. Sent from my iPhone using Tapatalk
  2. Aussieyobbo16

    issue with dual fuel xg

    I was just looking at a tridon one for 25$ from supercheap. Are they a good enough brand or would a ford genuine piece be a better move Sent from my iPhone using Tapatalk
  3. Aussieyobbo16

    issue with dual fuel xg

    Makes sense. There wasn’t a thermostat in it when I bought it. I just left it cos I’ve seen scenarios where older cars run better without the thermostat and I assumed that was the case with this particular one Sent from my iPhone using Tapatalk
  4. Aussieyobbo16

    issue with dual fuel xg

    There’s no thermostat. Air filters probably due for replacement having done 20k km. Sent from my iPhone using Tapatalk
  5. Aussieyobbo16

    issue with dual fuel xg

    ive got a dual fuel xg ute fitted with an 85 litre usable tank. first issue is it wont tart on lpg, it has to be started on petrol then manually switched to lpg. second issue is its dreadful economy, its running about 22l/100km on petrol and closer to 37l/100km on gas. does anyone know what i can do to solve this problem or where abouts in gippsland or melbourne areas i can take it to get a decent tune done.
  6. Aussieyobbo16

    Odometer stopped

    ive got a haynes book for eb/ed that has a supplement for xg thats actually prety handy. you dont need to remove the steering but its considerablly eaier than tryna manouvre it around the wheel.
  7. Aussieyobbo16

    Instrument cluster.

    Had to change the cluster back to the xg one today. Something to do with changing caused it to be running like shit and eventually at all on gas. Any ideas what might be the cause.
  8. Aussieyobbo16

    Instrument cluster.

    I think ya might be right. Everything else seemed to be working fine earlier. Sent from my iPhone using Tapatalk
  9. Aussieyobbo16

    Instrument cluster.

    anyone know what this plug is for. Goes in near fuel gauge on old cluster and the Ed one doesn’t have a plug for it. Sent from my iPhone using Tapatalk
  10. Aussieyobbo16

    Instrument cluster.

    Hi all. I’ve gotta get a new instrument cluster for my xg column auto ute. Do I have to get xg specific cluster or can I fit something else in there. If so what’s easiest to get and fit
  11. Aussieyobbo16

    Xg wiring butchery

    Would anyone happen to know what might be the cause of problems with an aftermarket head unit (running aerpro plug and play harness) it shuts of randomly while driving as if there’s a short somewhere and also anytime I press the brake or let off the throttle. Could this be linked to a problem I seem to be having with the ecu. Or just crappy wiring. Or whatever butchery (and there’s a lot) happened before I owned it. Tia
  12. Aussieyobbo16

    Xg problem child.

    Yeah I’ve really only got this weekend to be changin a motor and it’s sposed to raining. Think imma try and find one that’s gonna cost more than 300$ to buy and hope it ain’t got so many gremlins. Sent from my iPhone using Tapatalk
  13. Aussieyobbo16

    Xg problem child.

    i had this issue with My XG, it turned out to be the IGNITION SWITCH(bit behind the lock assy with the wires coming out. ) these are pinned in(unlike XF etc that have grub screws) I wouldn’t doubt a problem with the ignition cos it had been removed and replaced with a xh barrel that didn’t fit when I bought it and I have since replace the majority of the ignition system. Honestly thinking it’s worth just buying another one cos I don’t have the time or money to keep sorting these issues out. Sent from my iPhone using Tapatalk
  14. Aussieyobbo16

    Xg problem child.

    So my xgs got a blown head gasket and god knows what else wrong with it. I have fairly easily access to an au that’s in dedicated gas and has a Tickford 4.0l in it. Wondering what problems imma run into putting that in the xg on dual fuel. Also give that it’s not yet regoed would this give me a problem with Rwc in vic. There also seems to be a major electrical issue that’s causing it to start but not continue to run as well as keeping all the lights on when the key is on. I unfortunately don’t have a code reader so I can’t find out if there’s anything wrong on that side of thing. Pls help I kinda really need it on the road this month.
  15. Aussieyobbo16

    Xg wipers stuffed.

    Au motor had same plug and basic shape. But the shaft that connects to the linkages Is the wrong shape. I tried to swap em around but they’re setup too different. Stripper the original motor down and cleaned it and out it back together again. Havnt managed to get it reinstalled yet. Sent from my iPhone using Tapatalk
×