Jump to content

Search the Community

Showing results for tags 'ford 250 crossflow 4.1 falcon cortina'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OzFalcon
    • OzFalcon News
    • New Member Introductions
    • Site Feedback
  • General
    • The Pits
    • Videos
  • Merlin's Metalcraft Emporium
    • Panel Beating Tech
    • Paint Tech
  • Technical
    • 6 Cylinder Tech
    • V8 Tech
    • Forced Induction Tech
    • Exhaust
    • Body and Exterior
    • Transmission and Differential
    • Suspension and Brakes
    • Cooling System
    • Interior and Car Audio
    • Auto Electrics
    • LPG Tech
    • Cortys and Eskys
    • Effies
    • Wheels and Tyres
  • Projects
    • Extreme Builds
    • Member Builds
    • Showroom
    • DIY
  • Trash 'n' Treasure
    • The Car Yard
    • The Wreckers
    • Non Car Related Sales
    • Wanted

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi, I am looking for some ideas to help fix an alloy head 250 crossflow that breaks down at 3500 to 4000 rpm. Beautiful till that point. This is an on going problem and have thrown a lot of money and parts at it with no success. I will give a brief description of engine mods and what has been tried so far. Maybe someone knows what I have missed. Alloy C2 head , Ported with large valves fitted. Hydraulic Camtech cam (CT324 528) intake lift .534" ex lift.534" lobe sep 110 , Dur 230 and 230 ( cam dialled in ) , Johnson anti pump lifters and hardened push rods , roller rockers and heavy valve springs. Aussie speed 4bbl intake , Holley Carb , Electric fuel pump from 5-8 psi , 10.5:1 comp ratio , balanced bottom end. Ignition is Bosch electronic dizzy module removed and running off MSD 6al digital box and MSD Coil. Dizzy was graphed to suit engine. Vaccume advance locked off. Has had the breaking down issue since engine was built. originally had high volume oil pump , been swapped out for standard ( no change) , tried various Carbs from 465 to 650 DP Holley no change. tried TFI dizzy no change , tried various leads , plugs , coils even swapped 6al no change , have had fuel pressure all the way as high as 8 psi no good. Have changed valve springs retainers and collets. Started with valve seat pressures on the conservative side and have now increased probably a little on the heavy side and no change. ( my son is an engine machinist he did this so , don't know seat pressures off the top of my head ) Engine is in a TE Cortina. I have run out of ideas and will probably swap the lifters out for a new set and only other thing I haven't paid much attention to is plug gaps just set them to whatever MSD recommended. I have probably missed some things I have tried , but if anyone has some ideas I am listening. Cheers
×