Jump to content

Lankymanxg

Members
  • Content Count

    12
  • Joined

  • Last visited

  1. Lankymanxg

    Power steering belt replacement

    I just checked and your right it's the alternator belt,seems a little loose,what do I have to do to tighten it?
  2. Lankymanxg

    Power steering belt replacement

    It's an xg ute with the 4.0 six
  3. Lankymanxg

    Power steering belt replacement

    On start up one of the belts squeel for 10-20 seconds then drops and I think it's the power steering belt and I'm just wandering what's involved in tightening it,it's my first Ford so I'm unfamiliar with the tensioner
  4. Lankymanxg

    Fuel pump issue

    Yea I always seem to find something,I took the spark plugs out and cleaned them and one of the boots on a spark plug lead was split,taped it up for now and seems to be idling fine now
  5. Lankymanxg

    Fuel pump issue

    Yea I had a look it does have some rust so I'll give it a clean as best I can,I would drain the fuel and do it properly but don't have enough containers for an almost full tank,I might change fuel filter cos it looks old,might even pull it out just to see if it's blocked
  6. Lankymanxg

    Fuel pump issue

    Ok I might give it a go cleaning it,as for condensation it seems normal to me,no different to any other car,had a look under the car at the fuel filter and it looks old could that be an issue,fun times..car troubles with no funds to fix it haha
  7. Lankymanxg

    Fuel pump issue

    Yea I'll go get one,what would be the best way to check for crud? Just by eye or is is safe to feel around in the tank,if it helps I've only had the car a week and the fuel pump got louder after a couple days,I don't think it would but would low octane fuel hurt it,I could of got a bad batch too
  8. Lankymanxg

    Fuel pump issue

    Ok I've got another issue with my xg,first thing in the morning I start it and it seems to idle rough till it warms up and also my fuel pump doesn't stop buzzing/humming the whole time it's running,does this mean the pump is about to fail,I don't like the idea of being stranded with a stuffed pump
  9. Lankymanxg

    Broken wire on fuel sender

    I've been having fuel gauge issues and I took the pump and sender out and there's a broken wire on it, there's a white wire and a black wire,the white one is disconnected and has a tiny bit of solder on the end,if anyone could put a picture up of where it goes I'd appreciate it
  10. Lankymanxg

    Xg fuel gauge issue

    Hi guys I'm having trouble with the fuel gauge in my xg,usually when I start it up it says it's 100% for a while then eventually the gauge drops to empty,could it be the cluster (odo doesn't work and temp gauge can be funny too) or the sender unit?
×