Jump to content
Squiz

clutch fan locks on

Recommended Posts

Sounds like it's buggered........ They should spin (but be firm to turn) and the wind should take over as your speed increases, to reduce drag on the engine. Sounds like yours is locked on and pushing against the wind. You only need the fan at the lights, or in a shopping centre, could delete it and run a Thermo?  Twin EF or AU is common. 

Share this post


Link to post
Share on other sites

It’s a common thing for them to lock up. They fail to free spin and really roar which only robs power and wastes fuel. The fan hub should undo with a 32mm spanner and it’s left hand thread. The hub removes from the fan with 4 bolts and you just put a new hub inside of the fan. I’m not sure how hard the fan hub is to buy these days but I think CHESTNUTXE might have one that he was willing to give away.

Share this post


Link to post
Share on other sites

There is a way to check the rpm of the fan and see if it's working properly, was reading about it in the Ford workshop manual. I'll post it up tonight if I remember.

Fan hubs are still available new, won't be on the shelf but I know Repco keeps them in their warehouses.

https://www.repco.com.au/en/parts-service/cooling/cooling-fans-components/dayco-fan-clutch/p/A7517033

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×