Jump to content

Search the Community

Showing results for tags 'radio not working'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OzFalcon
    • OzFalcon News
    • New Member Introductions
    • Site Feedback
  • General
    • The Pits
    • Videos
  • Merlin's Metalcraft Emporium
    • Panel Beating Tech
    • Paint Tech
  • Technical
    • 6 Cylinder Tech
    • V8 Tech
    • Forced Induction Tech
    • Exhaust
    • Body and Exterior
    • Transmission and Differential
    • Suspension and Brakes
    • Cooling System
    • Interior and Car Audio
    • Auto Electrics
    • LPG Tech
    • Cortys and Eskys
    • Effies
    • Wheels and Tyres
  • Projects
    • Extreme Builds
    • Member Builds
    • Showroom
    • DIY
  • Trash 'n' Treasure
    • The Car Yard
    • The Wreckers
    • Non Car Related Sales
    • Wanted

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Michael.Charalambous

    Ford XF radio

    Hey boys I have a 1985 xf with the factory radio and speakers. The radio has stopped working. When you turn the knob of the volume on and all the way up you can hear static so wondering if the radios cooked or speakers blown? Has this happened to anyone else? Any suggestions on how to fix it?
×