blackxt

Members
  • Content count

    527
  • Joined

  • Last visited

  • Days Won

    4

blackxt last won the day on November 3 2017

blackxt had the most liked content!

1 Follower

About blackxt

  • Rank
    Advanced Member

Recent Profile Visitors

3,088 profile views
  1. My guess my first engine was from a lpg running car , with a lot of k's on it .. Sent from my iPhone using Tapatalk
  2. Bit going on still .... New engine coming soon .. cars not going ATM as I had a drama with a rod that decided to bend and eject its self out the sump .. after searching for a decent replacement decided stuff it and just get the good engine done .. Not sure why the other engine let go .. but after pulling the head off and seing how far the valves were pulled into the head it was a surprise it ran at all .. Sent from my iPhone using Tapatalk
  3. Not to say my hei dizzy isn't working , but I no at the boost I plan to run the coil won't keep up . So I'm upgrading to a 6al-2 programable and stock el dizzy .. at least then I can plot out some curve and put some more early on timing in . If I wanted to stay around the ten psi mark I would just leave the hei dizzy in . This is something I had allways planned todo .. I like the simplicity of the hei job just to get it running .. but at 20-25 psi it will just blow the spark out on stock coil .. and I'll have to run timing to low and it will lag like hell .. Sent from my iPhone using Tapatalk
  4. Perhaps put it to microtech to make a replacement for the failing ghia dashes .. Sent from my iPhone using Tapatalk
  5. I've been pretty flat out putting the motor in and what not , and it's been a mad rush so I could drive it yesterday sorting and calibrating my microtech dash .. Not sure about drag challange , I'm on the mailing list .. guess I just need to make it fast now and hope for the best . Sent from my iPhone using Tapatalk
  6. Busy weekend , the car is nicely tuned now .. I had to make a few custom jets to get it right . Took it on a cruise Sunday with a local car club , racked up a few ks , sat on the hwy with 3.7 diff gears and the three speed pretty well , it goes well for a simple setup I'm also pretty impressed with my $80 motor . Motivation is low to work on it , so I'll start building my good motor now .. edging closer to the drag challenge goal . Sent from my iPhone using Tapatalk
  7. More wiring .. it's pretty hard to get a picture of this , it's my 5" microtech prodash .. I hated all the autometer gauges , I've consolidated them into one now , the dash also has gps speedo and can measure 1/4 mile times and is also a logger .. Sent from my iPhone using Tapatalk
  8. These tyres will probably be to big , I will go back to a 255 tyres I think , this is with 275/60/15 .. Eventually these will be my main wheels , once I get two rims for the front to paint. Cars going pretty well , has a slight miss in cylinder 3 , but the more I drive it the better it gets , might be a stuck ring or leaky valve .. not bad for a $80 engine that's in it ATM ... Sent from my iPhone using Tapatalk
  9. It might have had something todo with the chopped springs that were in the front .. most of them seem to buckle the shock towers a little .. this ones pretty bad that's for sure . I'll probably cut it out one day and weld some better plate into it .. Sent from my iPhone using Tapatalk
  10. Got to take it for a test drive .. it's fairly laggy ATM , and only running a 7psi spring . But seems to work very well if you stall it up a bit .. Still lots todo over the next few months .. but now it runs and drive I'll probably recoupe some cash and start on the good motor for it .. Sent from my iPhone using Tapatalk
  11. Yeah it will happen .. im waiting on my idler pulley to turn up so I can put the drive belt on .. I'm that keen I've just been running it for a short time and driving it out the shed .. if only I had of ran it on methonol this would not be a issue . Sent from my iPhone using Tapatalk
  12. Those pictures I uploaded yesterday where fairly average, so i tried harder . Sent from my iPhone using Tapatalk
  13. Cheers .. it could be much nicer .. but it works . Sent from my iPhone using Tapatalk
  14. After busting my arse for the last few weeks the car fired up today .. I still need a few little things before I can drive it , but it ran and moved under its own power . It's only running a 7psi spring and one gas converter , that will keep me happy until i finish building my good engine .. I could have also gone all out and painted the engine bay , but seeing the paint on the outside isn't fantastic I decided to leave it and run with a ratty theme , instead of things getting out of hand . Sent from my iPhone using Tapatalk
  15. Also kinda boring update .. I've redone most of the wiring . Just needs a few loose ends tidied up .. But basically pulled the old loom back through the bay , pulled it apart ,ran the ones I needed over the floor .. and run a new power cable to power up the dash and accessories.. I'm putting a microtech dash in it so I made a panel to hold that also .. Sent from my iPhone using Tapatalk